Какую версию выбрать ? Печать
Автор: Administrator   
26.07.2010 06:59


Сейчас доступны 2 различные версии Joomla: Joomla 1.0 и Joomla 1.5. Вы не знаете какую версию выбрать в качестве движка? Очень часто задается этот вопрос при создания сайта на Джумле. Для этого, были записаны 2 видео-урока в вип-зоне, которая доступна только для клиентов. Давайте проведем сравнение двух версий.

Как видно на первый взгляд, отличие версий кроется в версиях Джумлы, но на самом деле это два различных движка.

Joomla 1.0 – это та же мамба, только немного модифицированная. А Joomla 1.5 написана почти с нуля, на разработку движка ушло около 2-х лет и в наше время начинают делать заплатки с дырами движка. За время существования движка (6 месяцев) вышло 8 обновлений с исправлением критических уязвимостей.

Версия 1.5 потребляет больше ресурсов, тем самым более нагружая ваш хостинг. Из этого следует, что Joomla 1.5 требует более мощный сервер, т.к. к-во данных для передачи возрастает практически в 2 раза по сравнению с младшей версией, а также необходимо больше места на жестком диске хостера.

И при остальных условиях работа Джумла 1.5 существенно медленнее, нежели Джумла 1.0.

При инсталляции Joomla 1.0, вы сможете без труда реализовать множество функций, которые вы хотите видеть на своем сайте. Все это делается очень просто, прикладывая наименьшее количество усилий.

 

В версии 1.5 это пока труднодоступно, потому как движок был переписан полностью, соответственно и все расширения нужно переписывать либо дорабатывать. Множество расширений Joomla 1.0 не совместимы с Joomla 1.5. Но в Джумла 1.5 имеется режим совместимости (legacy), позволяющий запускать расширения от Джумла 1.0, но как показывает практика – это не всегда дает 100% результат.

В связи с этим, на данный момент рекомендуется инсталляция Джумлы 1.0, потому что с ее помощью можно создать полнофункциональные проекты, и не боятся что они будут плохо и нестабильно работать.

Обновлено 26.07.2010 07:00